Help icon product icon
Translation
Installation and Troubleshooting - Knowledge Base
          Go back Back to Table of Contents

General Migration Cook Book

Migration Overview


Terms

You can preserve your program settings and user work documents when migrating your program from one computer to another. However, there are some manual steps to follow. Migration considerations on the New Computer can stem from several possible issues: 1) Folder paths may be different so the program cannot locate a referenced resource file; 2) Windows Special Folders (ie Documents) may have different physical paths on every computer; 3) Hardware (ex audio/video) cards may be detected by Windows with a different identifier even if the same physical device is installed to the New Computer.


Migration Steps Outline
  1. Copy program settings file - This file contains all the settings you may have made in the program Options dialog and other program settings.
  2. Transfer user work documents - These are the user work documents you have saved with the program File > Save menu item. (Sound Lists, Media Lists, etc.)
  3. Transfer media files - The media files (audio, video, images, external programs, etc.) referenced by your user work documents need to be copied to the new machine.
  4. Manual migration of user work documents - Each user work document may have specific migration steps as detailed below.
  5. License Transfer - (Do this last!) You will need to follow the Program License Transfer Procedure if you are transferring the program license to a new computer.

Windows Special Folders

The User Documents folder is located in different physical path locations on Windows XP versus Windows® 10/8/7/Vista . And your Windows logon userid is part of the path. So even if both computers are the same operating system type, these folder paths will vary for each computer.


What you will need

General Migration Steps and Tips

These are optional general tips that can make migration a bit easier.


Tips

Perform the follow steps in order.

Step 1 - Install program on New Computer

  1. Download the latest program installer release from our website to the New Computer and run the installer.
  2. Once the program is installed, open the program. This step will create program User Documents folder needed in subsequent steps.
  3. Obtain a temporary activation key for the New Computer so that you can have both computer installs activated during migration. There are automatic restrictions enforced on the evaluation key system (for hacker mitigation). If you get a "Duplicate request" error, simply email support to request the temporary key.
  4. Activate the program on the New Computer, then close it.

Step 2 - Copy program settings file

On the Old Computer, go to Tools > Options Port > Export. Save the export file to be copied to the new New Computer. Copy the file to a USB memory stick for transfer.

On the New Computer, go to Tools > Options Port > Import. Open the exported settings file.

Make sure the program is closed when performing the steps below.

Step 3 - Transfer user work documents

On the Old Computer, locate your user work documents (SoundLists, MediaLists, etc) in the User Documents folder to the memory stick. (you may have used a different user documents folder by changing it in the program Options dialog)

On the New Computer, copy your user work documents from the memory stick to the User Documents folder (or whereever you want to save your user work documents).

Step 4 - Transfer media files

On the Old Computer, locate all the media files (audio, video, images, external programs, etc.) that you use with the program. Copy those folders to the memory stick.

On the New Computer, copy the media folders from the memory stick. (see the Tip above about "Folder paths" about the best way to copy these folders.)

Step 5 - Check for Migration Errors

Now re-open the program. You may see a warning or error message reported on the program status bar. Any warnings usually require a manual step to resolve the error. See the program specific migration steps listed below for possible mitigation steps. Please report any problems you cannot resolve to Support.

Clear the Clear Recent Files List since it likely contains file paths from the New Computer ( File > Clear Recent Files List ).

Step 6 - Transfer the Program License

If you are transferring the program license from the Old Computer to the New Computer, you will need to follow the Program License Transfer Procedure before you can use your activation key on the New Computer. Deactivation is a necessary step to complete migration of the license key.

Step 7 - Validate Your Work Files

The first time you open any migrated work file on the New Computer, run validation on it to check for migration errors. (Tools > Validation)