Product icon Help book icon Sound Mill X3 - User's Guide

Tools menu

Locator: Sound List Editor > Tools .

The Tools menu has the following functions.

  • Options - Set Program Options. See the Options section in this Help document for full details.
  • Options Port - These functions offer a way to port a copy of your program Options to another computer.
    • Import - Pops up a File Open Browse dialog to open a previously saved file copy of program Options. The imported Options replace your current program Options. It is recommended that you stop any running automation when doing an import since the Automator uses some Options.
    • Export - Pops up a File Save dialog to save a copy of your current program Options. The Saved Options file type extension is ".DAT". (ex. MyOptions.dat)
    • Reset - Warning USE CAREFULLY! Resets ALL Options to factory default values. There is no Undo for this operation. You will lose all your Options and Favorites customizations including: Automation, Output Group definitions and other Favorites. You may first want to Export your current Options as a backup in case you want to restore them later. It is a good practice to take screen shots of all the Options tabs if you want to manually restore some settings after the reset.
  • Sound Design Report - Generates a Sound Design Report (aka Sound Plot) listing the contents of all Sound Items and Scripts . You can save or print the report in the resulting text viewer. The Options > Reports dialog allows you to customize different levels of detail.
  • Repair moved file paths - If you move an Media File to another folder location, you need to reset the Sound Item so it points to the new location. This repair feature can automatically reset multiple Sound Items Media File paths when files get moved. You specify a target folder where the files were moved to and it will reset file paths for any matching filenames in that folder. This also works for External Program definitions if the external program file is moved.
  • Sound List Validation Check - This will run a validation check on the current Sound List to find any obvious settings errors or invalid Id references or duplicate Ids.
  • Settings Validation Check - This will run a validation check on your program settings and configuration to find any obvious settings errors. Run this if you are experiencing problems and are not getting error messages to help diagnose the problem. It will check audio soundcard Devices definitions, Output Groups, External Program definitions, Time Periods and the list of recognized Media File extensions.
  • Fix All Duplicate Ids - Warning! Changing Ids (identifiers) could invalidate some Id references (See the section on Ids for details). This will fix instances of duplicate Ids (which could occur after Importing another Sound List). This will generate a new Id for any duplicate Ids found (includes Sound Items, Scripts, Playlists or External Program definitions). The first found instance of an Id is left unchanged. Subsequent duplicates are replaced with a new unique Id. It is recommended that you generate and save a Sound List Report prior to running this action so that you can determine where any references are pointing to. Turn on (check) Show Ids in the Report Options before running the report.
  • Output / Devices - See separate Help page for Output / Devices .
  • Automation
    • View Automation Settings - Preview all the current Automation settings.
    • Time Periods - Edit and save custom Time Periods for use with schedules. These can be used in the Schedule Editor for setting the Start and End Time. Edit will open the Time Period Editor. Reset will set the favorite to the factory defaults. See the Time Periods section for how Time Periods work.
    • Favorite Schedule - Edit and save a Favorite Schedule. This can be used in the Schedule Editor to quickly set a schedule to a favorite. Reset will set the favorite to the factory default values.
    • External Programs - Edit and save your External Programs definitions. See the External Program Editor for details.
    • IPC Controls - See the separate IPC Controls section.
  • Playlist Logs
    • View Today's Play Log - Opens the current day's Playlist Log file in a text editor. See the Playlist Logging options section for information and options regarding Playlist Logs.
    • Pick Play Log to View - Pops up a file selection dialog to pick a previous day's Playlist Log file to open.
  • Manage Favorite Colors - Add and Edit Favorite Colors. This provides a productivity feature to edit once and reuse Color Groups. You can create as many favorites as you like. Editing is done with the Color Group Editor.
  • Manage Favorite Fonts - Add and Edit Favorite Fonts. This provides a productivity feature to configure once and reuse Fonts. You can create as many favorites as you like.
  • Custom Shortcuts Keys - See the separate Custom Shortcuts Keys page for details.
  • Quick Markers - See the separate Quick Markers section for details.

Sound Item Default Attributes

The Tools > Default Attributes menu items operate based on the current Default Attributes Mode .

  • View Default Attributes - Displays the current Sound Item Default Attributes (based on which Default Attributes Mode you are using).
  • Save Selected Attributes as Defaults - You can replace the current Default Attributes as often as you like. Select any Sound Item in your list. Then click this menu item (or the Save as Default Attributes button on the Find tool bar. The attributes of the Sound Item are saved as the current Default values.
  • Restore Defaults Attributes from Factory Settings - Restores the Default Attributes to factory settings.
  • Set All from 'Defaults' (All Attribute Groups) - Sets all attributes for all attributes groups (above) from the defaults. Applies to all Sound Items in the list. Includes Play Controls, Play Modifiers, and Locator Attributes Groups.