Breakthru Software
Translation
"Breaking down barriers to your innovation."

Prerequisites

Hardware

  • Microsoft Windows-based computer - There are no special hardware requirements for this program. It has been tested on Laptop and Desktop computers.
  • System Architecture - This product runs in 64bit mode on x64 systems and 32bit mode on x86(32bit) systems. The same installer covers both system types.
  • Graphics card or onboard graphics - A good quality graphics card is recommended (although not required) for best quality and performance sound.

Software

The following are the required software levels to run the program. The Microsoft .Net Framework are NOT installed automatically by Windows Update and may not have been pre-installed by your computer manufacturer. So you may need to download and install them yourself.

See the Installation and Troubleshooting Knowledge Base Verifying and Installing Prerequisites sections for complete instructions and download links.

  • Windows LogoOperating System - Windows® 10/8/7/Vista - All versions of Windows 10/8/7/Vista - x64 (64bit), x86(32bit) and "N" editions for all versions. (See a few exceptions.)
  • Microsoft .Net Framework 4.6 - Should come pre-installed on Win10 computers. On Windows 8 or earlier, you may need to install .Net 4.6 separately (Free download). Do not uninstall previous versions of .Net unless you have a reason to do so. They are meant to reside side by side and you may disable another program by uninstalling a previous version of .Net. For Win XP, see Windows XP prereqs.
  • Microsoft Windows Media Player (version 11, 12 or later) - Version 11 or later. Windows Media Player(WMP) drivers are used as the audio interface. WMP version 10 should work also according to Microsoft documentation but it is not officially supported. All of our testing is currently done with WMP version 12.

Operating Systems

Windows logo Our products run on:
Windows 10/8/7/Vista/XP SP3
64bit, 32bit, and "N" editions
(See a few exceptions and see note on XP support.)